您好,欢迎来到爱go旅游网。
搜索
您的当前位置:首页NYOJ-5 Binary String Matching

NYOJ-5 Binary String Matching

来源:爱go旅游网

Binary String Matching

时间: 3000 ms  |  内存: 65535 KB
难度: 3
描述
Given two strings A and B, whose alphabet consist only ‘0’ and ‘1’. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is ‘1001110110’ while the pattern string A is ‘11’, you should output 3, because the pattern A appeared at the posit
输入
The first line consist only one integer N, indicates N cases follows. In each case, there are two lines, the first line gives the string A, length (A) <= 10, and the second line gives the string B, length (B) <= 1000. And it is guaranteed that B is always longer than A.
输出
For each case, output a single line consist a single integer, tells how many times do B appears as a substring of A.
样例输入
3
11
1001110110
101
110010010010001
1010
110100010101011 
样例输出
3
0
3 

代码如下:

#include<iostream>
#include<string.h>
using namespace std;
char a[15],b[1005];
int main()
{
	int n;
	cin>>n;
	while(n--)
	{
		int ans=0;
		cin>>a>>b;
		int m=strlen(a);
		int l=strlen(b);
		for(int i=0;i<l;i++)
		{
			if(strncmp(a,&b[i],m)==0)//strncmp函数
				ans++;
		}
		cout<<ans<<endl;
	}
	return 0;
 } 

因篇幅问题不能全部显示,请点此查看更多更全内容

Copyright © 2019- igat.cn 版权所有 赣ICP备2024042791号-1

违法及侵权请联系:TEL:199 1889 7713 E-MAIL:2724546146@qq.com

本站由北京市万商天勤律师事务所王兴未律师提供法律服务